• Category Archives Cisco UCS
  • VMware vSphere 5.1 Known Issues : Updated 9/17/2012

    VMware released vSphere 5.1 at VMworld 2012 in San Francisco and with any new product release there are usually bumps on the road, compatibility issues and things that just don’t work. VMware vSphere 5.1 is no exception.

    I have been part of many beta tests for other companies as well as several vSphere editions going back to 3.x. Not every configuration and product can be tested. The beta process does catch a lot of issues. The day software goes live without any issues every time, a lot of people will be without work..

    I have decided to catalog a few of the known issues with the vSphere 5.1 release.

    Perhaps the larges issue is that VMware View and vSphere 5.1 are not compatible yet.

    Last Updated 09/30/2012

    vSphere 5.1 and VMware View (all versions of View) 

    VMware vSphere 5.1 is not currently supported with any versions of VMware View.

    Do not upgrade vSphere above the supported versions listed in the VMware View 5.1 Release Notes.

    vSphere 5.1 is in the process of being certified against VMware View. To be alerted when this article is updated, click Subscribe to Document on the link above in the actions box

    VMware vSphere 5.1 and Cisco UCS

    Read Chad Sakacc’s post for more details. vSphere 5.1 support on Cisco UCS, the VMEM needs a new vSphere 5.1 specific .vib.

    VMware vSphere 5.1 KB articles

    VMware complied several of the 5.1 KB articles in a recent blog post on VMware Support Insider blog

    More VMware vSphere 5.1 KB articles  ** Added 9/17/2012 **

    VMware has compiled more vSphere 5.1 KB articles that you may have missed. This one features a few of the Single Sign-On (SSO) issues that have been common for some of you

    vCenter Server Services hang on startup after upgrading to vCenter Server 5.1 

    From the VMware KB article: Follow the link for resolution

    • After upgrading to vCenter Server 5.1, the VMware VirtualCenter Server service fails to start
    • The VMware VirtualCenter Server service will not successfully stop or start.
    • The vpxd log files show the following:
      • The final log in the vpxd.log file shows:
        CoreDump: Writing minidump
    • You see a backtrace near the very bottom of the vpxd.log file which begins with the following:

    2012-09-13T11:53:46.802+02:00 [04468 info ‘vmmoVm’ opID=SWI-c5103928] [VmMo::SetComputeCompatibilityDirty] vm vm-5345 is marked dirty
    2012-09-13T11:53:46.786+02:00 [05112 warning ‘win32vpxdOsLayer_win32’ opID=SWI-56f04b9c] [VpxUnhandledException] Backtrace

    Increased Restart time with vCenter Server 5.1

    This issue only impacts the start/re-start time for vCenter Server. It does not affect the ongoing operations after vCenter Server has started. In fact, due to improvements to the vCenter Server database, the use of vSphere Web Client, the Inventory Service cache, customers will notice significant performance improvements in vCenter Server 5.1.

    VMware vSphere 5.1 and EMC VMAX arrays.

    Sphere 5.1 changes the behavior of VAAI Hardware Accelerated Locking (aka ATS) to no longer work with transient (sometimes on/sometimes off) ATS behavior, and older (i.e. non-current) versions of Enginuity will fail to create VMFS-5.

    VMware vSphere 5.1 and EMC PowerPath V/E 

              **** Updated 09/26/2012 Resolved *** – Fix is out.

    PowerPath/VE customers, hold off vSphere 5.1 upgrades (GA was yesterday).   Hotfix P02 from EMC is in days, and so is the expected VMware fix, follow the above link for more details on Chad Sakac’s blog post

    VMware vSphere 5.1 and Synology DSM 4.1   ** Blog updated on 9/18/2012 **

    Kendrick Coleman found an issue with the most recent release of DSM 4.1 and vSphere 5.1

    It’s possible to mount both NFS and iSCSI datastores, but when you try to build or power on a VM, everything begins to halt when it needs to write to disk. If everything runs in memory (like mounting an ISO and beginning an OS installation), but when it comes to install the OS to disk, it begins to crawl. I checked the vmkernel log and here is what is shown. You can see that after I power on the VM, it gets binded to a port but when it tries to read from disk, there are all sorts of errors 

    Update Manager 5.1 reports the compliance status as Incompatible when scanning or remediating ESXi 5.x hosts that belong to an HA cluster 

    I personally ran into this issue when upgrading my lab – see Update Manager 5.1 Release Notes

    CA Signed SSL Certificates may cause trouble with the upgrade process of vCenter.

    From Michael Webster’s blog at http://longwhiteclouds.com/

    I have heard unconfirmed reports of difficulties with the upgrade process of vCenter particularly with registering Inventory Service and SSO with vCenter when using CA Signed SSL Certificates. As I’m using CA Signed Certificates in my lab environment I will update this article when I have completed my upgrade.

    Troubleshooting SSL certificate updates and Single Sign On (2033240)
    vCenter Single Sign On installer reports: Error 29155. Identity source discovery error (2034374)

    ESXi cannot distinguish between EagerZeroedThick & LazyZeroedThick
    From Cormac Hogan’s Blog

    ESXi cannot distinguish between thick provision lazy zeroed and thick provision eager zeroed virtual disks on NFS datastores with Hardware Acceleration support

     When you use NFS datastores that support Hardware Acceleration, the vSphere Client allows you to create virtual disks in Thick Provision Lazy Zeroed (zeroedthick) or Thick Provision Eager Zeroed (eagerzeroedthick) format. However, when you check the disk type on the Virtual Machine Properties dialog box, the Disk Provisioning section always shows Thick Provision Eager Zeroed as the disk format no matter which format you selected during the disk creation. ESXi does not distinguish between lazy zeroed and eager zeroed virtual disks on NFS datastores.

    VMware vSphere 5.1 iPXE problems with AutoDeploy

     If you are having issues with IPXE and AutoDeploy please read Gabe’s Virtual World

    VMware Support Insider: ALERT: Full disk on vShield Edge 5.1.x fails with error: VIX_E_DISK_FULL ERROR

    Added 09/30/2012

    VMware has become aware of an issue whereby vCloud Networking and Security 5.1 release can go into an Edge disk full state approximately 14 days after the first edge is deployed.

    Symptoms include:

    • In vCloud Director, attempting a reconfig fails with this error:VIX_E_DISK_FULL
    • In vCloud Director, when looking at Edge Gateways, you receive this error:Edge VM backing the edge gateway is unreachable

    For further updates and more information on this alert, refer to KB article:
    Full disk on vShield Edge 5.1.x fails with error: VIX_E_DISK_FULL ERROR (2035939)

    Links for more information
    vSphere 5.1 Important Upgrade Considerations by Michael Webster VCDX #66 

    As with any upgrade please carefully consider especially before implementing in production. Reach out to your partners and trusted advisers for guidance so they can evaluate your environment to minimize issues.

  • Varrow Lunch & Learn Series VMware View on Cisco UCS

    Are you interested in VMware View and Cisco UCS and have questions. Are you going to be in the Carolinas or Virginia in the near future. If so you are in luck. Varrow is hosting a series of Lunch and Learn events about VMware View on Cisco UCS hosted by Dave Lawrence. Come join us,  you won’t be dissapointed.

    In these presentations, we’ll explore:

    • What’s new with VMware View 5.1
    • The New Storage Accelerator – See how this technology is dramatically changing VDI storage design
    • How to leverage VDI to significantly reduce costs
    • How UCS’ scalability and VMware integration helps VDI reach its full potential
    • Demo – View Client for iPad – it’s a game changer & it’s cool!

    Join us for lunch and you will have an opportunity to experience the powerful benefits of the advanced feature set available in VMware View’s virtual desktop infrastructure. These are the advanced features that convinced Gartner Group to name VMware View the clear solution leader and visionary in the virtual desktop arena. We will also demo a live VMware View environment showing you the View Manager, and a few different clients.

    Cisco UCS has seen an amazing adoption rate due to its single management, impressive scalability, and the best VMware integration features of any server platform. These combine to make it the best platform for hosting VMware View.

    Related Links
    Other upcoming Varrow Events – Check back here often. I will try to keep you updated as well
    Dave Lawrence’s Blog – VMguy

    Now don’t get your hopes up about me being there, I will be out delivering these solutions, somebody has to get the work done 😉

  • UCS 2.0 Emulator

    You have probably all heard about the upstart Cisco entering the blade market a few years ago with the UCS platform. Have you always wanted to get your hands on it but you don’t want to buy your own, not everyone can have UCS at home or even work. Well here is your chance to. Cisco has a UCS emulator currently on version 2.0 that you can run as a virtual machine in your VMware virtual environment.

    You can find the download here
    Click here to download.

    Cisco UCS Platform Emulator is packaged as a compact virtual machine (VM) with the CentOS open source
    Linux distribution. This VM can run a Cisco UCS Manager multichassis, multiblade simulation on a laptop
    or desktop computer and does not require an internet connection.Cisco UCS Platform Emulator is delivered as a zip file. The filename of the zip file includes the Cisco UCS Platform Emulator release number, such as
    Cisco_UCS_Platform_Emulator_v2.0.99180.370305.zip. The file size is approximately 300
    to 400 MB.


    Before installing Cisco UCS Platform Emulator, ensure the system meets the following requirements:
    • 1 GB free RAM
    • 6 GB disk space
    • 1.8-GHz single CPU
    • A Mozilla-compatible browser (Firefox or Google Chrome)

    • Java Runtime Environment 1.6 that you can download from